fbpx

الملايين من مستخدمي “أندرويد” و”ويندوز” و”آيفون” قد يفقدون الوصول إلى الإنترنت خلال أيام قليلة!

قد تكون ملايين الأجهزة، بما في ذلك هواتف “أندرويد” و”ويندوز” و”آيفون”، على بعد أيام فقط من فقدان الوصول إلى الإنترنت بالكامل.

وحذر خبير أمني من أن التغيير القادم الذي سيبدأ يوم الخميس 30 سبتمبر، قد تكون له تداعيات كبيرة على مجموعة واسعة من الأجهزة التي تنتجها أسماء مألوفة رائدة. ويعود سبب حظر الإنترنت المحتمل إلى بروتوكول أمان HTTPS.

وحتى إذا لم تكن معتادا على المصطلحات التقنية، فمن المحتمل أنك سمعت – أو تكون على دراية – بـ HTTPS (المعروف أيضا بـHypertext Transfer Protocol Secure “بروتوكول نقل النص التشعبي الآمن”).

وعندما تزور موقعا إلكترونيا في متصفحات مثل Chrome، ربما تكون لاحظت رمز قفل في شريط العناوين.

ويشير هذا إلى أن موقع الويب يستخدم HTTPS، ما يعني أن الموقع آمن وأي معلومات تدخلها محمية. فلماذا هذا مهم لمستخدمي “أندرويد” و”آيفون” و”ويندوز”؟.

في يوم الخميس 30 سبتمبر، ستنتهي صلاحية شهادة الجذر – التي تُستخدم لتشفير الاتصالات بين الأجهزة والويب، وهي ضرورية لبروتوكول HTTPS.

وبعد هذا التاريخ، لن تثق الأجهزة ومتصفحات الويب في شهادات معينة تسمى IdentTrust DST Root CA X3.

وبالنسبة للغالبية العظمى من الأجهزة، لن يتسبب ذلك في حدوث مشكلات. ولكن بالنسبة للأجهزة القديمة التي لم تُحدّث منذ سنوات (ولن يحق لها استخدام الشهادة الجديدة)، فقد يتسبب ذلك في فقدها الوصول إلى الإنترنت.

وهذا وفقا لمدونة من سكوت هيلم، حيث يراهن الباحث الأمني ​​”على الأرجح أن بعض الأشياء ستتعطل” يوم الخميس القادم.

إقرأ المزيد
 

وفي مقال عبر الإنترنت، قال هيلم: “لن تكون هذه هي المرة الأولى التي تنتهي فيها صلاحية شهادة المرجع المصدق الجذري وأتصور أنها ستتبع اتجاه انتهاء الصلاحية السابقة نفسه، حيث تتعطل الأشياء. وإذا انتهت صلاحية شهادة الجذر التي ترتكز عليها سلسلة الشهادات الخاصة بك، هناك فرصة جيدة لأن تتسبب في فشل الأشياء”.

وأصدرت الشهادات الجذرية المتأثرة من قبل منظمة Let’s Encrypt غير الربحية، والتي أصدرت في المجمل أكثر من ملياري شهادة – وهو ما يمثل جزءا كبيرا من الويب.

وبالنسبة لمستخدمي “آيفون”، تحتاج إلى التأكد من عدم تشغيل تحديث أقل من iOS 10. وبالنسبة لمستخدمي الهواتف الذكية التي تعمل بنظام “أندرويد”، تأكد من عدم تشغيل الإصدار 7.1.1 من برنامج غوغل.

ويحتاج مستخدمو “ويندوز” إلى التأكد من عدم تشغيل أي شيء أقل من Windows XP SP3. وإذا كان لديك جهاز Mac، فأنت بحاجة إلى التأكد من عدم تشغيل إصدار أقل من 10.12.1.

وفيما يلي قائمة كاملة بإصدارات البرامج المتأثرة:

– OpenSSL <= 1.0.2

– Windows < XP SP3

– macOS < 10.12.1

– iOS < 10 (آيفون 5 هو أقل طراز يمكنه الوصول إلى iOS 10)

– “أندرويد” <7.1.1 

– Mozilla Firefox <50

– أوبونتو <16.04

– دبيان <8

– جافا 8 <8u141

جافا 7 <7u151

– NSS <3.26

– Amazon FireOS (متصفح الحرير)